博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
杭电ACM 1241解题报告
阅读量:5163 次
发布时间:2019-06-13

本文共 2209 字,大约阅读时间需要 7 分钟。

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5937    Accepted Submission(s): 3461

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 
Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 
Sample Output
0 1 2 2
 
代码:
#include<stdio.h>
int p[8][2]={
{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
char ch[100][100];
int m,n;
void search(int x,int y)
{
      int i,xx,yy;
      for(i=0;i<8;i++)
     {
         xx=x+p[i][0];
         yy=y+p[i][1];
         if(xx<0||xx>=m||yy<0||yy>=n)
              continue;
         if(ch[xx][yy]=='*')
              continue;
         ch[xx][yy]='*';
         search(xx,yy);               
     }    
}
int main()
{
  int i,j,count;
  while(scanf("%d%d",&m,&n)&&m+n)
  {
   for(i=0;i<m;i++)
  scanf("%s",ch[i]);
   count=0;
   for(i=0;i<m;i++)
    for(j=0;j<n;j++)
    {
     if(ch[i][j]=='@')
     {
      search(i,j);
      count++;
     }               
    }                    
    printf("%d\n",count);
  }   
 return 0;
}
 

转载于:https://www.cnblogs.com/Reack/archive/2012/11/05/2755736.html

你可能感兴趣的文章
Linux 下常见目录及其功能
查看>>
开源框架中常用的php函数
查看>>
nginx 的提升多个小文件访问的性能模块
查看>>
set&map
查看>>
集合类总结
查看>>
4.AE中的缩放,书签
查看>>
CVE-2014-6321 && MS14-066 Microsoft Schannel Remote Code Execution Vulnerability Analysis
查看>>
给一次重新选择的机会_您还会选择程序员吗?
查看>>
Mysql MHA高可用集群架构
查看>>
心急的C小加
查看>>
编译原理 First,Follow,select集求法
查看>>
java 浅拷贝和深拷贝
查看>>
vue实例中中data属性三种写法
查看>>
uva1636 - Headshot(条件概率)
查看>>
iOS开发 runtime实现原理以及实际开发中的应用
查看>>
BZOJ2437 NOI2011兔兔与蛋蛋(二分图匹配+博弈)
查看>>
android 学习资源网址
查看>>
shell基础
查看>>
2018.1.15
查看>>
[集合DP] UVA 10651 Pebble Solitaire
查看>>